Symptoms

An attempt to change the value of Billing Model, Billing Period, or Align Billing Order with Statement Day in a Service Plan results in an error:

This Plan has been delegated to Resellers. You are not allowed to modify Recurring Type.
This Plan has been delegated to Resellers. You are not allowed to modify Billing Period.
This Plan has been delegated to Resellers. You are not allowed to modify Billing Period Type.

Cause

The Service Plan was delegated to resellers. It is not possible to alter the Billing Model, Billing Period, or Align Billing Order with Statement Day value for delegated plans.


Resolution

There is no convenient way to change Billing Model, Billing Period, or Align Billing Order with Statement Day of a Service Plan if it was delegated. Feature Request PFR-40 is intended to improve this scenario. Until it is implemented, the only way is to create a new Service Plan with the desired configuration and switch the existing subscriptions to it:

  1. Create a new plan or clone the existing one and change the required settings;
  2. Delegate the new plan to the resellers;
  3. In Reseller's Control Panel, configure the upgrade path from the old plan to the new one;
  4. Switch customers' subscriptions.

Additional notes

It is currently impossible to switch the Service Plan's billing model between Before Billing Period and After Billing Period. These models utilize completely different billing models, and there is no automated way to recalculate subscription prices and convert periods. There is a feature request PFR-752 to implement this functionality.

See also

There is also a way to get the error message:

This Plan has been delegated to Resellers. You are not allowed to modify Billing Period Type.

This behavior is described in a solution article It is not possible to modify a delegated Service Plan: "You are not allowed to modify Billing Period Type".