Symptoms

The Provider configured integration between PBA and Kayako Fusion. The Kayako Fusion server uses the MySQL 5.5 database server.

When a customer tries to access the 'Support Tickets' section in the PBA Customer Control Panel the following error message is displayed:

Session cannot be inited because user was not found

Cause

During the PBA and Kayako integration, the special table must be created in the Kayako database. Syntax of the table creation is not supported in the MySQL 5.5.

Resolution

The problem is resolved in PBA 5.5.2 in scope of the request PBA-51793.

If upgarde is not possible at the moment, correct the kayakofusion.php file located on the Kayako server:

  • Find the following SQL query to create the hspcomplete table in the script:

    $_SWIFT->Database->Query('
        CREATE TABLE `hspcomplete` (
        `hspcomplete` INT(10) UNSIGNED NOT NULL,
        `supportsuite` INT(10) UNSIGNED NOT NULL,
        `email_confirmed` INT(1) UNSIGNED NOT NULL,
        PRIMARY KEY (`hspcomplete`)
        ) TYPE=MyISAM
    ');
    
  • Change TYPE=MyISAM to ENGINE=MyISAM.

  • Save changes in the script.

Internal content