Symptoms

A new customer with the 'Per Account' billing type (consolidated billing) was created in PBA. The customer placed several orders on the day when it was created. The first order was invoiced immediately in accordance with the consolidated billing feature design.

Then, during the very next Daily Billing process PBA generated consolidated invoice for other orders the customer placed earlier.

So, Consolidated Invoice was generated on the next or the same day after account creation, not on the next account Statement Date as Provider and customer expected.

Cause

This is expected behavior in the following situation:

After placing an order a new customer with the 'Per Account' billing type was created. Day of customer creation is set as the Statement Date for their account. The same day customer placed more orders. For all these orders consolidated invoice will be generated by the nearest Daily Billing Process.

Consolidated invoice is generated on the account Statement Date, even if it is first day when account was created. During the Daily Billing process PBA checked if invoice was already created (on Statement Date) - invoice was not created, so PBA generated Consolidated Iinvoice for customer's orders.

Resolution

PBA documentation will be adjusted in scope of the request PBA-51083, it will describe the mentioned above behavior.

Internal content