Symptoms

Provider cannot change the 'Charge for Subscription' option in the existing Service Plan in PBA Control Panel between the 'Before Subscription/Billing Period' and 'After Billing Period' values even if the plan does not have any active customer subscription, all subscriptions based on the plan are canceled or terminated.

When trying to change the 'Charge for Subscription' option the following error message is displayed:

You can't switch Recurring Type between pre-paid and post-paid because subscriptions are present.

Cause

In current PBA version billing type change is not possible in a Service Plan even if all exsiting subscriptions based on the plan are canceled/terminated.

Resolution

Create the new Service Plan with the desired billing type. Use the 'Clone Existing Plan' option to create new Service Plan with the same settings as in the original plan.

Internal content