Symptoms

The customer is logged in to the Control Panel using the language other than English. The link (Details) is not localized in the last step of the upgrade wizard in CCP:

The same issue can be observed when placing a renewal order from CCP.

Cause

In the current product version this link cannot be localized, this is going to be corrected in future versions.

Workaround

  1. Make sure the directory /usr/local/bm/conf/wnd/BM/customization/customization is a symlink to /usr/local/bm/customization:

    # ls -ld /usr/local/bm/conf/wnd/BM/customization/customization
    /usr/local/bm/conf/wnd/BM/customization/customization -> /usr/local/bm/customization
    

    If not, configure it as described in Preparing Container chapter:

  2. a) For upgrade wizard

    Create the customization file /usr/local/bm/customization/UpgradeOperation_PlaceUpgradeOrder_FinishWin.xml on PBA Application Server that will redefine this word on the screen:

    <window id="UpgradeOperation_PlaceUpgradeOrder_FinishWin">
         <elements>
            <href id="OrderDescr" overwrite_value="(Detalles)"/>
         </elements>
     </window>
    
  3. b) For renewal order placement wizard

    Create the customization file /usr/local/bm/customization/OrderConfirmation_PaymentForOrderStatusWin.xml that will redefine the word:

    <window id="OrderConfirmation_PaymentForOrderStatusWin">
      <elements>
        <href id="OrderDescr" overwrite_value="(Detalles)"/>
      </elements>
    </window>
    
  4. Restart the www container on the PBA Application Server for the changes to apply:

    /etc/init.d/www restart
    

Note that with the workaround proposed you will see the link (Detalles) even if you login under any locale.

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