Symptoms

Parallels Key Administrator (KA) plug-in has the 'Not in Sync' status in PBA Provider Control Panel, it synchronization fails with the error message like below:

License Classes not in sync: PLESK_95, PLESK_95_FOR_VZ, PLESK_95_PLUS_FOR_VZ

Depending on PBA installation different license classes can be listed in the error message.

Cause

Listed license classes are no longer supported by Parallels KA and are not available for purchase. See more details in the Parallels Knowledgebase article #113401 [INFO] Older Plesk Versions – End of Purchase Ability.

However, obsolete license classes are still present in the list of published license classes in PBA, and probably they are used in Service Plans.

Resolution

  1. Remove the obsolete license resources from the Service Plans where they are used - remove corresponding Resource Rates from Service Plans.

  2. Unpublish obsolete license classes in PBA Provider Control Panel at External Systems Director > License Manager > Plug-ins > KA plug-in > License Classes.

    The detailed instructions can be found in PBA documentation: Resolving License Classes List Mismatch After Synchronization.

  3. In case the obsolete license classes are used in Service Plans delegated to resellers and their reseller branding subscriptions are terminated already, delegated plans and terminated subscriptions will not be synchronized using the steps above and as a result the KA plug-in will stay in 'Not in Sync' status.

    To solve the problem empty the 'Command' parameter in the obsolete license resources in PBA:

    1. Go to Product Director > Resource Manager > Resources
    2. Click on the obsolete license resource
    3. Empty the 'Command' field:

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