Symptoms
An attempt to transfer a domain in the Business Automation (BA) Control Panel results in the following error message:
Can not transfer Domain. Domain is already registered.
Cause
The domain is already registered under the Provider's account in the registrar and cannot be transferred again.
During a domain transfer order, BA sends a request to the registrar configured as the Domain Availability Checker for the proper TLD (Top-Level Domain). Then, the registrar replies that the domain is already registered under the Provider's account.
As a result, the order to transfer the domain cannot be placed.
Resolution
Solution 1
The domain can be migrated to BA via the API. The following sequence of API methods is used for domain subscription creation:
- DomainSubscrAdd_API - Creates a domain subscription in BA
- pem.addSubscription - Creates the default DNS hosting subscription in Operations Automation (OA) with the same ID as the domain subscription in BA (created in step 1)
- pem.addDomain - Assigns DNS hosting for the domain to OA's default DNS subscription.
- DomainExtDataAdd_API - add domain service parameters (AuthInfo, Login, Password, etc) if required.
Refer to the BA documentation for more details: Domain Subscription Migration
Solution 2
- Log into the BA Provider Control Panel
- Go to System > Settings > Domains > TLDs
- Click on the required domain zone and change the availability checker to a different registrar than the one currently configured
- Place a transfer order for the domain
- The order will fail (because the domain is already registered with the registrar)
- Complete the failed order using the Domain Conflict Resolver
- Revert the changes for the domain zone made in step 3 above