Symptoms
A mailbox is not displayed in customer's Global Address List in OWA or Outlook.
Cause
Customer set the 'Show in Address Book' property to 'No' for the mailbox in POA Customer Control Panel.
Resolution
In POA Customer Control Panel open the mailbox that is not displayed in GAL, and in 'General' tab check the 'Show in Address Book' parameter. If it is set to 'No', click 'Edit' and change to 'Yes':
POA will generate a background task with name like this - "Show in address book mailbox '' (id=)", make sure that the task was processed successfully in POA Task Manager.