Symptoms

A customer cannot create mailbox in their Hosted Exchange subscription in POA Control Panel, the following error message is shown:

The system can not find mailbox store suitable for provisioning.

At the same time the entry like below may be found in the debug log poa.debug.log on POA Management Node:

Feb 14 18:51:44 poa : DBG [1:17136:b4af6b90:80 1:17136:b4af6b90 lib]: [txn:710216 Exchange::domainArea::OrganizationEntity::getAvailableMailboxSt]
{module_id="Exchange"; code="111"} There are no ready to provide mailbox stores or capacities are exceeded for all existing mailbox stores on the host #18.

The problem also may appear in POA Provider Control Panel when upgrading Exchange organization to the next version, the error message is as follows:

There are no ready to provide mailbox stores or capacities are exceeded for all existing mailbox stores on the host

Cause

Exchange mailbox stores are either misconfigured or out of capacity.

Resolution

Follow the instructions below to solve the problem.

  • Log into POA Provider Control Panel
  • Go to Service Director > Hosted Exchange Manager > Mailbox Stores
  • Make sure all the following requirements are satisfied:

    • There is at least one mailbox store marked as 'Ready to Provide' with status 'Ready'.
    • A mailbox store marked as Ready to Provide and whose status is Ready has enough diskspace to create customer's mailbox: compare the desired size which customer want to set for their new mailbox with the available disk capacity of the proper mailbox store shown in the Free column
    • The proper Provisioning Attribute is assigned to the mailbox stores which are Ready to Provide and Ready:
    • Go to the customer subscription in POA Provider CP
    • Click on the Service Template the subscription is based on
    • Switch to the Resources tab
    • Find the attribute assigned to the Hosted Exchange resource type in the Provisioning attributes column
    • Return to the Exchange mailbox stores list and for all good mailbox stores (marked as Ready to Provide and Ready) make sure that the same attribute is assigned to the mailbox store on the 'Attributes' tab in store properties
  • See the screenshot with important parameters to check:

Important: check the value of the 'Provision mailboxes of a subscription to the same mail store' activation parameter of the Hosted Exchange resource type of the Service Template the problem customer subscription is based on:

  • Go to the problem customer subscription
  • Click on the Service Template
  • Switch to the Resources tab
  • Click on the Hosted Exchange resource
  • Switch to the Activation Parameters tab

    If the parameter set to 'Yes, try to use same store' and customer already has Exchange mailboxes in their subscription then in the procedure above you need to check not all Exchange mailbox stores but only the mailbox store where existing mailboxes in the problem subscription are located. You may find on which mailbox store customer's mailboxes are located in POA Provider CP at Service Director > Hosted Exchange Manager > Mailboxes, search by subscription ID. Check the capacity, Ready to Provide and Ready parameters mentioned above for the found mailbox store in this case.


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