Symptoms
In POA, Office 365 tasks fail with this error message:
Can not create DNS record for <FQDN> of type TXT. There is existing record.
See the example below:
Task name APS application 'Microsoft Office 365', id 180, instance 4068 -> service 'customer', instance 7506: executing configuration script
Last execution output Can not create DNS record for '<FQDN>' of type TXT. There is existing record with id <ID> and data '"v=spf1 include:outlook.com ~all"'._
Cause
The srv_records.php/srv_records.py script described in the Office 365 Known Issue: SRV Records for Lync Online Are Not Created Automatically KB article was customized in the following way:
This customized script creates DNS TXT records when new subscriptions are provisioned. These DNS TXT records are created through the POA Public API.
- The created DNS TXT records are marked as "MANUAL."
After that, the subsequent APS configuration tasks fail because the Office 365 APS application cannot create/update DNS TXT records. The application cannot create/update DNS TXT records because the APS service controller does not allow the creation of a DNS record if there are already DNS records of the same type that were created manually or by another APS application.
Resolution
For Microsoft Office 365 Application 4.4 and higher:
Revert the srv_records.py script to the "canonical" form. Set the Text of SPF DNS records global setting of the appropriate Office 365 Application Resource Type to the proper value (the v=spf1 include:outlook.com ~all value is default).
- Extract the content of the updateDNSRecords.zip file. Run the updateDNSRecords.py script. This script is configured in the same way as is described in this KB article: #112991. The script updates the DNS TXT records created by the customized srv_records.py script as if they were created by the Office 365 application.
Note: An individual subscription can be fixed as follows: remove the "MANUAL" DNS TXT record for the domain mentioned in task's execution output; restart the failed task.
For Microsoft Office 365 Application 4.3 and lower:
Revert the srv_records.php script to the "canonical" form. Set the Text of SPF DNS records global setting of the appropriate Office 365 Application Resource Type to the proper value (the v=spf1 include:outlook.com ~all value is default).
- Run the attached script, updateDNSRecords.php. This script is configured in the same way as is described in this KB article: #112991. The script updates the DNS TXT records created by the customized srv_records.php script as if they were created by the Office 365 application.
Note: An individual subscription can be fixed as follows: remove the "MANUAL" DNS TXT record for the domain mentioned in task's execution output; restart the failed task.