Symptoms
Provisioning of a Plesk subscription fails with the following error:
2062 Error Failed #177 Provision client to Plesk
Process provisioning for document; Plesk gate for Node #PLID was not initialized
127.0.0.1
26-Oct-2013, 12:53
Attention! See Problem # p2013-10-26_07-53-39 for details.
Here are the details:
/var/log/hspc/p2013-10-26_07-53-39
---8<---
[2013/10/26 07:53:39] [DEBUG] [7977] [HSPC::MT::Plesk::PleskGate::__send_request_to_agent] Sending packet to %Plesk_node_ip% : 8443 : /enterprise/control/agent.php
[2013/10/26 07:53:39] [DEBUG] [7977] [HSPC::MT::Plesk::PleskGate::__send_request_to_agent] Final Packet=<packet version="1.3.5.1"><server><get_protos/></server></packet>
[2013/10/26 07:53:39] [DEBUG] [7977] [HSPC::MT::Plesk::PleskGate::__send_request_to_agent] REPLY_DATA=<?xml version="1.0"?>
<packet version="1.3.5.1">
<system>
<status>error</status>
<errcode>11003</errcode>
<errtext>PleskAPIInvalidSecretKeyException : Invalid secret key usage. Please check logs for details.</errtext>
</system> </packet>
--->8---
(where #PLID
and %Plesk_node_ip%
are the ID and IP address of the Plesk node)
Also, the Plesk node has a status of Not available
at Top > Service Director > Plesk Manager > Nodes
.
Cause
The Plesk secret key is assigned to an invalid IP address, i.e., not the IP address of the PBA-S node:
[root@Plesk_node ~]# /usr/local/psa/bin/secret_key --list Key: 2004cca62b7a2f32a9de7c26110f2726 Ip: %wrong_PBAS_node_ip% Description: PBAS [root@Plesk_node ~]#
The IP address of the PBA-S node is
%PBAS_node_ip%
:[root@PBAS_node ~]# /sbin/ifconfig | grep %PBAS_node_ip% inet addr:%PBAS_node_ip% P-t-P:%PBAS_node_ip% Bcast:%PBAS_node_ip% Mask:255.255.255.255 [root@PBAS_node ~]# [root@PBAS_node ~]# grep SERVER_IP /etc/hspc/hspc.conf SERVER_IP = %PBAS_node_ip% [root@PBAS_node ~]#
PBA-S connects to the Plesk node via another IP address. Try connecting to the Plesk node from the PBA-S:
[root@PBAS_node ~]# telnet %Plesk_node_ip% 8443 Trying %Plesk_node_ip%... Connected to %Plesk_node_ip%. Escape character is '^]'.
Verify the connection in the Plesk node:
[root@Plesk_node ~]# netstat -antp | grep 8443 tcp 0 0 0.0.0.0:8443 0.0.0.0:* LISTEN 7281/sw-cp-server tcp 0 0 %Plesk_node_ip%:8443 %PBAS_node_ip%:36625 ESTABLISHED 7283/sw-cp-server
The Plesk node sees the IP address of the PBA-S node as
%PBAS_node_ip%
, but another IP address is set in the Plesk secret key:[root@Plesk_node ~]# /usr/local/psa/bin/secret_key --list Key: 2004cca62b7a2f32a9de7c26110f2726 Ip: %another_PBAS_node_ip% <== !!! Description: PBAS [root@Plesk_node ~]#
Resolution
Update the preferences of the Plesk node in PBA-S. First, set the Plesk administrator password:
Top > Service Director > Plesk Manager > Nodes > PLESK_NODE > General Settings > Edit
Run the periodic task
Update Plesk nodes stats info
atTop > Configuration Director > Logging and Errors > Action Log > Tasks Queue
There are two ways to resolve the misconfiguration:
Reconfigure network settings so the PBA-S node connects to Plesk via the IP address
%another_PBAS_node_ip%
.Change the IP address to
%PBAS_node_ip%
in the PBA-S configuration:/etc/hspc/hspc.conf --->8--- SERVER_IP = %PBAS_node_ip% ---8<---
Restart
hspcd
service (/etc/init.d/hspcd restart
) to apply the changes. Then repeat the actions from point #1.