Symptoms

The VNC console for a virtual machine in Parallels Virtual Automation (PVA) or Power Panel (PP) does not work and gives the following error :

Network error: Socket is not connected

Cause

The VNC console in PVA / PP uses offline management technology to connect to the virtual machine (VM) via the VNC protocol. To make this work, the following conditions should be met :

  • The VM should have VNC settings configured correctly
  • The VM should have the vzpp-desktop offline service enabled
  • The VM should have a valid network configuration
  • Connecting to the hardware node on port 4649 should be possible
  • The VM in bridged mode should be connected to that node's interface which is used by the node itself for external communication

Resolution

NOTE: If there is no network configuration on the VM yet (For example, if the VNC connection is required to perform an operating system (OS) installation), you need to disable the vzpp-desktop offline service (in the VM's general settings) completely. This way, the VNC connection will be established directly with the Parallels Cloud Server (PCS) host server, which poses security risks as the VNC protocol is insecure by its nature. Once the OS installation is complete, enable vzpp-desktop again.

  1. Make sure the VNC settings for the Virtual Machine are configured correctly.

    In PVA, go to Infrastructure > Hardware node > Virtual machine > Configure > General Settings, expand the "Remote Display" section and verify that the Remote Display Service is enabled.

    Alternatively, this can be checked from the server backend :

    ~# prlctl list -i -f <VM_NAME> | grep Remote
    

    The correct output should be similar to:

    [root@host ~]# prlctl list -i -f test-vm | grep Remote
    Remote display: mode=auto address=0.0.0.0
    Remote display state: running
    

    To enable the Remote Display Service for the VM with the default settings:

    ~# prlctl set <VM_NAME> --vnc-mode auto --vnc-passwd <passwd>
    
  2. Make sure the vzpp-desktop service is enabled.

    In PVA, go to Infrastructure > Hardware node > Virtual machine > Configure > General Settings, expand the "Offline Management" section and choose either of the two settings :

    • Enabled with default settings
    • Enabled with custom settings with 'Port 4649' selected

    Alternatively, configure it from the server backend with the command:

    ~# prlctl set <VM_NAME> --offline_management on --offline_service vzpp-desktop
    

    NOTE: The command in this example only enables the vzpp-desktop service. If you need more services to be configured, you should list them all, separated by a comma.

  3. Make sure the network settings for the virtual machine are valid and its IP address is routable. Test network connectivity to the VM from outside the hardware node.

  4. Make sure port 4649 is accessible from your location. Test the connectivity with basic network utilities. For example, use telnet :

    ~# telnet <node_ip_address> 4649
    

    Check that port 4649 is actually listening on the hardware node :

    ~# netstat -ntlp | grep :4649
    

    The correct output should be :

    [root@host ~]# netstat -ntlp | grep :4649
    tcp        0      0 0.0.0.0:4649                0.0.0.0:*                   LISTEN      536158/init
    tcp        0      0 :::4649                     :::*                        LISTEN      536158/init
    

    If port 4649 is not listening, check that:

    • Container 1 exists and is running:

      [root@host ~]# vzlist 1 -H
           1          3 running   192.168.161.108 -
      
    • The pvappd and pvaagentd processes are running:

      [root@host ~]# pvapp status
      pvappd (pid  196378) is running...
      [root@host ~]# pvaagent status
      pvaagentd (pid  195981) is running...
      
  5. The VM in bridged mode should be connected to that node's interface which is used by the node itself for external communication.

    The server can have several Ethernet interfaces (physical NICs, VLANs and so on) and virtual environments can be connected to any such interface. This can result in asymmetric routing if the VM is connected to an interface which is not used for default routing.

If any of the above conditions are not satisfied, PVA Agent and PVA Power Panel service health should be checked. The Troubleshooting Power Panel (VZPP) issues article may help in this case.

Related topics

113732 Power Panel for Virtual Machines best practices

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