Symptoms

Provider has two Service Plans in PBA with different Auto-Renewal settings in them - PlanA and PlanB.

A customer switched subscription from the PlanA to the PlanB.

The Auto-Renewal option of the subscription was not updated according to the settings from the new Service Plan PlanB.

Cause

This is by-design behaviour of PBA, the Auto-Renewal setting is considered to be a property of a particular subscription, not a Service Plan.

Resolution

Use one of the ways provided below to resolve the problem.

Resolution #1. Synchronize the subscription with the new Service Plan, make sure to check the 'Update Subscription Service Terms' option during the synchronization:

Subscription synchronization with the new Service Plan will update the Auto-Renewal option to be in sync with the value set in the current Service Plan unless the parameter has been changed manually by the subscription owner or Provider in the past. If the Auto-Renewal parameter was customized then subscription synchronization will not update it, proceed with the resolution #2 below in this case.

Resolution #2. Set the Auto-Renewal option for a particular subscription to the desired value manually in the subscription properties in PBA Provider or Customer Control Panel.

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