Search Engine: Elastic

Article ID: 2540, created on Oct 29, 2007, last review on Apr 18, 2012

  • Applies to:
  • Pro Control Panel Linux


View Knowledge
Knowledge ID 1673
Product : WEBppliance for Linux
Version : 3.1.5
Topic : FAQ

WEBppliance 3.1.5 Security Patch (LS)

WEBppliance 3.1.5 Security Patch (LS)



WEBppliance 3.1.5-1 provides a security patch that resolves a buffer overflow error observed in PHP. 

Compatibility :

This patch requires WEBppliance 3.1.4 for Linux to be installed on your server.

NOTE: This patch will not install on any other version of WEBppliance for Linux, other then 3.1.4.

Major Features of WEBppliance 3.1.5

Patch provided for the following security issue :

1. Buffer overflow in PHP wordwrap function

    Heap-based buffer overflow in the wordwrap function in PHP after 4.1.2 and
    before 4.3.0 may allow attackers to cause a denial of service or execute arbitrary code.

    Advisory details for the security patch are available at the following URL:

Installation instructions :

Download site: (be sure to download using BINARY mode)

To install the patch please follow the instructions below :

1.  Download the file LS-3.1.5-1.tar.gz. 

2.  Uncompress the file:
  tar -xvzf LS-3.1.5-1.tar.gz

3.  Change the current directory to the directory where you have uncompressed the file:
   cd LS-3.1.5-1

4.  Run the following command
  # sh ./
   After checking that this is the LS installation for LWP 3.1.4, this install script would upgrade the required rpms  (requires root access).

5.  Restart http server using the following command:
   # /sbin/service httpd restart

6.  Restart WEBppliance using the following command:
   # /sbin/service webppliance restart


Related Knowledge

Related Links
Last ModifiedUsageSatisfiedLast Used
8/20/2004 12:37:53 PM17 10/11/2007 6:45:10 AM

4cc899da08664637a8bc437308d3ddd7 3ccb419cf98083f3bb45808fba8dbc7c 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF