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Article ID: 134472, created on Aug 27, 2019, last review on Aug 29, 2019

  • Applies to:
  • Business Automation 8.0

Symptoms

  • Provider uses OA version 8.0
  • Service plan exists in BA but cannot be found in OSA APS-resources. It can be validated by executing request to APS-controller:

    [root@osscore ~]# curl -kE /usr/local/pem/APS/certificates/poa.pem "https://localhost:6308/aps/2/collections/service-plans?eq(planId,PLAN_ID)"
    []
    
  • Auxiliary SQL-query in BA database points to error javax.persistence.NoResultException: No entity found for query during plan creation in APS:

    pba=> SELECT * FROM "ChangeNotifications" WHERE "TableType" = 'SERVICE_PLAN' AND "EntityID" = 'YOUR_PLAN_ID' AND "Operation"= 'CREATE';
    -[ RECORD 1 ]+----------------------------------------------------------------------
    ChangeID     | 107580
    TableType    | SERVICE_PLAN
    EntityID     | YOUR_PLAN_ID
    ApsUUID      | 85c4fad4-e3fb-4213-8f7d-d1a06313d0d0
    Operation    | CREATE
    Output       | Error: javax.persistence.NoResultException: No entity found for query
    CreationTime | 2019-01-14 13:20:47.034362
    LastModified | 2019-01-14 13:20:47.034362
    Status       | FAILED
    

Note: Replace YOUR_PLAN_ID with real plan ID

Cause

It is a result of bug OA-3534 Billing plan synchronization fails with "No entity found"

Resolution

Bug OA-3534 is fixe in OA version 8.1. Please schedule upgrade to latest OA version.

After the upgrade please contact Cloudblue Technical Support in order to propagate affected service plans from BA to OSA APS.

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