Search Engine: Elastic

Article ID: 133965, created on Apr 25, 2019, last review on Apr 25, 2019

  • Applies to:
  • Operations Automation

Symptoms

User of reseller/provider subscribed to notification "Azure CSP Canceled Tenant Subscription Reseller Notification", but corresponding email is not received upon Azure subscription cancellation.

Task Send notification to user@contoso.com fails with the following output:

template 1000123:241 processing failed: The following has evaluated to null or missing:
==> AccountName [in template "1000123:241_nl_NL" at line 1, column 116]

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Tip: If the failing expression is known to be legally refer to something that's null or missing, either specify a default value like myOptionalVar!myDefault, or use <#if myOptionalVar??>when-present<#else>when-missing</#if>. (These only cover the last step of the expression; to cover the whole expression, use parenthesis: (myOptionalVar.foo)!myDefault, (myOptionalVar.foo)??
----

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FTL stack trace ("~" means nesting-related):
- Failed at: ${AccountName} [in template "1000123:241_nl_NL" at line 1, column 114]
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Azure CSP application version is 7.7.

Cause

Software-relate issue #APSA-21148.

Resolution

The issue is considered to be fixed in the future releases of the application. Contact you Technical Account Manager in order to clarify current status of the issue.

As a workaround, remove ${AccountName} placeholder from notification template "Azure CSP Canceled Tenant Subscription Reseller Notification":

Provider's Control Panel > Settings > Email Templates > Azure CSP Canceled Tenant Subscription Reseller Notification > Edit

Additionally it is required to cancel failed tasks since it is not possible to process them in current state.

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