Search Engine: Elastic

Article ID: 133375, created on Nov 6, 2018, last review on Feb 19, 2019

  • Applies to:
  • Operations Automation 8.0
  • Operations Automation 7.3
  • Operations Automation 7.4

Cause

OA 7.3, 7.4 and 8.0 supports PowerDNS Authoritative 4.1.x. The users who currently use PowerDNS Authoritative 3.x can update to the latest version of the server.

Resolution

To update to PowerDNS Authoritative 4.1.x, the following manual steps must be performed on PowerDNS service node:

  1. Remove the allow-recursion property in /etc/pdns/pdns.conf file. Alternatively, you can comment this line, for example:

    #allow-recursion=0.0.0.0/0
    

    For the property details, please refer to PowerDNS documentation.

  2. Update PowerDNS by running the commmand:

    yum install epel-release yum-plugin-priorities && curl -o /etc/yum.repos.d/powerdns-auth-41.repo https://repo.powerdns.com/repo-files/centos-auth-41.repo && yum --enablerepo=epel install pdns
    

    For details, please refer to PowerDNS repositories.

  3. Restart PowerDNS service:

    systemctl restart pdns
    

5356b422f65bdad1c3e9edca5d74a1ae 8fc71f07abe5b233fea1ae0377cd5e3d dd79f16c76b9dca75205ab5e9f5465ea 1941880841f714e458ae4dc3d9f3062d 55fe109b4b4fe3fbb893f22dbb85a41a adc6deaa66054d8a194d131ba07f2785 aab95f5cf9bcfa920cc1dda8487f084a

Email subscription for changes to this article
Save as PDF