Search Engine: Elastic

Article ID: 133178, created on Sep 14, 2018, last review on Sep 14, 2018

  • Applies to:
  • Operations Automation

Symptoms

Various Exchange-related tasks may fail.

The Exchange Management Console cannot connect to the local server. It shows the error like below:

VERBOSE: Connecting to EX2016-MBX01.example.com.
New-PSSession : [ex2016-mbx01.example.com] Connecting to remote server ex2016-mbx01.example.com failed
with the following error message : The WinRM client sent a request to an HTTP server and got a response saying the
requested HTTP URL was not available. This is usually returned by a HTTP server that does not support the
WS-Management protocol. For more information, see the about_Remote_Troubleshooting Help topic.

However, it is possible to connect to the same server from another computer:

[PS] C:\Windows\system32>Enter-PSSession -ComputerName EX2016-MBX01.example.com
[EX2016-MBX01.example.com]: PS C:\Users\pem_admin\Documents> hostname
EX2016-MBX01

Cause

The server EX2016-MBX01.example.com has 2 IP addresses:

  • 192.168.0.10 - bound to Default Web Site in IIS
  • 192.168.0.20 - bound to AutodiscoverRedirectSite in IIS

On resolving local hostname Windows takes an IP address with a higher value, regardless to actual DNS settings. As a result, the hostname EX2016-MBX01.example.com is resolved to the IP 192.168.0.20, which is not bound to Default Web Site. As a result, PowerShell cannot establish a connection.

Resolution

It is recommended to use an IP address with a higher value for the website Default Web Site on Exchange mailbox servers.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF