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Article ID: 133090, created on Aug 28, 2018, last review on Dec 6, 2018

  • Applies to:
  • Operations Automation

Symptoms

Office 365 Subdomain form is loaded incorrectly in the Online Store:

image

At the same time in PCP the form is displayed correctly.

The following entries can be seen in store.log:

[Aug,28 13:59:18][0047355][INFO][STORE]: GetAPSPlanToken_API for 123
[Aug,28 13:59:18][0047355][INFO][STORE]: STP::sendrecv
[Aug,28 13:59:18][0047355][INFO][STORE]: STP::~sendrecv execution timeout 0.036172866821289
[Aug,28 13:59:18][0047355][INFO][STORE]: Render::fetchTemplate. Template: pemgate.tpl.

As it can be seen by the entries above, incorrect Online Store Layout Template is loaded instead of the correct one (resourcegate.tpl).

Cause

  1. Impacted Service Plan contains resource rates with Show in store = No parameter. According to Office 365 Providers guide this value should be set to 'Yes'.

  2. Resource Category with Office 365 Resources is included into another Resource Category, which is not related to Office 365 and contains no such resources.

Resolution

  1. Set Show in store = Yes for all resource rates of impacted Service Plan (you can easily find needed SP it in /usr/local/bm/templatestore/var/log/store.log on the Online Store node). Synchronize the Online Store

  2. Detach Resource Category with Office 365 Resources from any other Resource Categories in Home > Products > Resources > Resource Categories > Parent Resource Category > Resource Categories tab Synchronize the Online Store

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