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Article ID: 132901, created on Jul 12, 2018, last review on Jul 12, 2018

  • Applies to:
  • Operations Automation 7.3

Symptoms

An Office 365 sales order or task Provisioning "Subscription" for APS application Office 365 fails with the error:

APS Application Error:
500 Internal Server Error
[ApplicationUnknownError] Unable to provision an offer named 'Dynamics 365 for Operations, Enterprise Edition Device' because there is no parent offer (names of possible parent offers: '')..

Cause

The mentione offer ( in this example Dynamics 365 for Operations, Enterprise Edition Device) was created in OA as an addon at PCP > Services > Applications > Office 365 > app instance > Addon Types. However, it had to be created of a license type.

Resolution

  1. Cancel the failed sales order
  2. Delete all resource rates based on this resource type from all service plans in Billing
  3. Delete the resource type from the service template
  4. Delete the resource type from PCP > Products > Resources
  5. Delete the addon resource from PCP > Services > Applications > Office 365 > app instance > Addon Types
  6. Create the license APS resource as describe in the documentation
  7. Create the license resource type representing the licese, as descibed in the documentation
  8. Add the newly created resource type to the service template
  9. Add the newly created resource to the corresponding service plans
  10. Place a new sales order.

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